Uploaded image for project: 'PhenoTips'
  1. PhenoTips
  2. PT-2378

Pedigree JSON import always assign the first object as proband (and export fails to specify proband node)

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Medium
    • Resolution: Fixed
    • Affects Version/s: 1.2.3
    • Fix Version/s: 1.2.4, 1.3-milestone-2
    • Component/s: None
    • Labels:
      None

      Description

      I imported the following
      [

      { "name": "f11", "sex": "female", "lifeStatus": "deceased" }

      ,

      { "name": "m11", "sex": "male" }

      ,

      { "name": "f12", "sex": "female", "disorders": [603235, "custom disorder"] }

      ,

      { "name": "m12", "sex": "male" }

      ,

      { "name": "m21", "sex": "male", "mother": "f11", "father": "m11" }

      ,

      { "name": "f21", "sex": "female", "mother": "f12", "father": "m12" }

      ,

      { "name": "ch1", "sex": "female", "mother": "f21", "father": "m21", "disorders": [603235], "proband": true }

      ]
      expecting to see node with name Ch1 be a proband. Instead node with name F11 Ithe very first one in JSON) was marked as proband.

      Please note that current version of fsdemo does not have this problem.

        Attachments

          Issue links

            Activity

              People

              • Assignee:
                asm Andriy Misyura
                Reporter:
                sasha Sasha Andjic
              • Votes:
                0 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: